BrightLily2007
Member

55 posts
3 reputation

IGN: BrightLily2007
By BrightLily2007 » 10 days ago
I like to play creative rush, but its only for 1.8.9 players. I am used to 1.12.2 combat and personally I prefer it. I think it would be better if items not available in 1.8.9 were banned, so that it is fair, but still let players on later versions play creative rush.

Alternatively, you could have separate servers for players on 1.12.2 or 1.14.4, that way it would be fair for people who like different versions
 





Creativity at its finest!!!



LunarWraith
Trial Moderator

7 posts
3 reputation

IGN: LunarWraith
By LunarWraith » 9 days ago
Playuhc uses 1.8.9 pvp so idk what you mean by 1.12.2 pvp. But it’s restricted to only 1.8.9 atm since 1.12.2+ players had a unfair advantage against others





sushi is worth the salmonella



BrightLily2007
Member

55 posts
3 reputation

IGN: BrightLily2007
By BrightLily2007 » 9 days ago
LunarWraith said: Playuhc uses 1.8.9 pvp so idk what you mean by 1.12.2 pvp. But it’s restricted to only 1.8.9 atm since 1.12.2+ players had a unfair advantage against others
Whenever I play on 1.12.2, the sword doesnt block like in 1.8.9. I realise that you could have an advantage due to the items available, but I think it would be fair if any items introduced later were not allowed.





Creativity at its finest!!!



PrivateLimitless
Member

23 posts
5 reputation

IGN: PrivateLimitless
By PrivateLimitless » 1 day ago
Yes, but just because you couldn't block while on 1.12 doesn't mean that 1.8.9 players weren't blocking while fighting.
And, yes, players on higher versions had unfair advantages on 1.8.9 players.







KaiNoMood
Admin

483 posts
42 reputation

IGN: KaiNoMood
By KaiNoMood » 1 day ago
I am sorry, but due to the huge advantages players with newer versions of Minecraft have in this game mode, this game mode will be available for 1.8.9 clients only.

Game modes with newer versions of Minecraft are WIP.